Herzlich willkommen

Compatibility with OneStepCheckout (the original)

Created at: 13 Dec 2016 | Updated at: 1 Mar 2021

Update 2019-05-10: This fix is now included in the latest version of OneStepCheckout.

In order to make the Idev OneStepCheckout fully compatible, you need to change one line of the Idev code.

Please open the file app/code/local/Idev/OneStepCheckout/Model/Observers/PresetDefaults.php and within the file, at the top, change from:

//@TODO together with refactoring system.xml: get rid of this variable and add them as config nodes
public $defaultFields = array('country_id', 'region', 'region_id', 'city', 'postcode');

To:

//@TODO together with refactoring system.xml: get rid of this variable and add them as config nodes
public $defaultFields = array('country_id', 'region', 'region_id', 'city', 'postcode', 'vat_id', 'vat_is_valid', 'vat_request_id', 'vat_request_success', 'vat_request_date', 'vat_trader_name','vat_trader_address');

Categories: Compatibility